$re = '/^(https?:\/\/)?([a-zA-z0-9]+)(\.[a-zA-z0-9]+)+(:[1-9][0-9]*)?\/.*$/m';
$str = 'http://vubpaperboy.com/asdjn?rtrwt=asdahb
https://vubpaperboy.com/asdjn?rtrwt=asdahb
vubpaperboy.com/asdjn?rtrwt=asdahb
http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb
https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb
qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb
https://subdomain.localhost:8000/
subdomain.localhost:8000/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);