import re
regex = re.compile(r"^(https?:\/\/)?([a-zA-z0-9]+)(\.[a-zA-z0-9]+)+(:[1-9][0-9]*)?\/.*$", flags=re.MULTILINE)
test_str = ("http://vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"https://vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"http://asdafyg.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"https://38trbfgbg54.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"qw478t487.vubpaperboy.com/asdjn?rtrwt=asdahb\n"
"https://subdomain.localhost:8000/\n"
"subdomain.localhost:8000/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")