$re = '/^(?=.*[a-z])(?=.*[A-Z]).{8,}$/m';
$str = 'Sahilgula
sahsilsaa
sdfdfdDsssd
sdfdd&ssD.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);