re = /^(?=.*[a-z])(?=.*[A-Z]).{8,}$/m
str = 'Sahilgula
sahsilsaa
sdfdfdDsssd
sdfdd&ssD.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end