import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[\\d.:]+[ \\t]+DEBUG[^\\n]*$)(.+?)(?=^[\\d.:]+[ \\t]+DEBUG|\\z)";
final String string = "01:15:21.882 DEBUG [SampleProcess] \n"
+ "Sample Message\n"
+ "01:15:21.882 DEBUG [SampleProcess1] \n"
+ "Summary Report\n"
+ "Sample Text1: 126\n"
+ "Sample Text2: 2330\n"
+ "Sample Text3: 2331\n"
+ "Sample Text4: 0\n"
+ "01:15:21.883 DEBUG [SampleProcess2]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}