import re
regex = re.compile(r"^(?=[\d.:]+[ \t]+DEBUG[^\n]*$)(.+?)(?=^[\d.:]+[ \t]+DEBUG|\z)", flags=re.MULTILINE | re.DOTALL)
test_str = ("01:15:21.882 DEBUG [SampleProcess] \n"
"Sample Message\n"
"01:15:21.882 DEBUG [SampleProcess1] \n"
"Summary Report\n"
"Sample Text1: 126\n"
"Sample Text2: 2330\n"
"Sample Text3: 2331\n"
"Sample Text4: 0\n"
"01:15:21.883 DEBUG [SampleProcess2]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")