$re = '/^2019(JE|PME|PEP|OP)[BDFGKRS]{1}[A-Z]{3}[0-9]{4}$/m';
$str = '2019OPKNIN1011
2019JEKNIN1011
2019PMEKNIN1011
2019PEPKNIN1011
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);