// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^2019(JE|PME|PEP|OP)[BDFGKRS]{1}[A-Z]{3}[0-9]{4}$").unwrap();
let string = "2019OPKNIN1011
2019JEKNIN1011
2019PMEKNIN1011
2019PEPKNIN1011
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}