using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""user\.ldap\.groups\.name""\s*=\s*""([^""]+)""(?!""user\.ldap\.groups\.name"")";
string input = @"""user.ldap.groups.name"" = ""M-Role13"" AND (""user.ldap.groups.name""= ""M Role1"" OR ""user.ldap.groups.name"" = ""M.Group-Role16"" OR ""user.ldap.groups.name""=""Admin Role"" ) AND ""common.platform"" = ""iOS"" AND ( AND ""ios.PersonalHotspotEnabled"" = true ) AND ""common.retired"" = False
""user.ldap.groups.name"" = ""M-Role13""user.ldap.groups.name"" AND (""user.ldap.groups.name""= ""M Role1"" OR ""user.ldap.groups.name"" = ""M.Group-Role16"" OR ""user.ldap.groups.name""=""Admin Role"" ) AND ""common.platform"" = ""iOS"" AND ( AND ""ios.PersonalHotspotEnabled"" = true ) AND ""common.retired"" = False";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}