import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"user\\.ldap\\.groups\\.name\"\\s*=\\s*\"([^\"]+)\"(?!\"user\\.ldap\\.groups\\.name\")";
final String string = "\"user.ldap.groups.name\" = \"M-Role13\" AND (\"user.ldap.groups.name\"= \"M Role1\" OR \"user.ldap.groups.name\" = \"M.Group-Role16\" OR \"user.ldap.groups.name\"=\"Admin Role\" ) AND \"common.platform\" = \"iOS\" AND ( AND \"ios.PersonalHotspotEnabled\" = true ) AND \"common.retired\" = False\n\n\n"
+ "\"user.ldap.groups.name\" = \"M-Role13\"\"user.ldap.groups.name\" AND (\"user.ldap.groups.name\"= \"M Role1\" OR \"user.ldap.groups.name\" = \"M.Group-Role16\" OR \"user.ldap.groups.name\"=\"Admin Role\" ) AND \"common.platform\" = \"iOS\" AND ( AND \"ios.PersonalHotspotEnabled\" = true ) AND \"common.retired\" = False";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}