$re = '/(?:^HOME|(?!\A)\G)\R*\K(?:(?!HOME).+\R*)*/m';
$str = 'HOME
this
could
have
many
lines
HOME
this
one
also
HOME
this
could
also
have
many
lines';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);