import re
regex = re.compile(r"(?:^HOME|(?!\A)\G)\R*\K(?:(?!HOME).+\R*)*", flags=re.MULTILINE)
test_str = ("HOME\n"
" this\n"
" could\n"
" have\n"
" many\n"
" lines\n"
"HOME\n"
" this\n"
" one\n"
" also\n"
"HOME\n"
" this\n"
" could\n"
" also\n"
" have\n"
" many\n"
" lines")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")