// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<browser>Android)\s(?P<major_version>\d+)\.(?P<minor_version>\d+\.?\d?);(?P<lang>\spt-br){0,1};{0,1}(?P<device>[ \w\-?]+)\s").unwrap();
let string = "20-03-2017 17:26:39
GET /ourapps.php HTTP/1.1
HTTP headers:
Accept-Language: pt-BR,en-US;q=0.8
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/5.0 (Linux; Android 5.1; 4017F Build/LMY47I; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/43.0.2357.121 Mobile Safari/537.36
Accept: application/json, text/plain, */*
Connection: close
20-03-2017 20:17:08
GET /ourapps.php HTTP/1.1
HTTP headers:
Accept-Charset: utf-8, iso-8859-1, utf-16, *;q=0.7
Accept-Language: pt-BR, en-US
Accept-Encoding: gzip,deflate
X-Wap-Profile: http://gsm.lge.com/html/gsm/E467f-M3-D1.xml
User-Agent: Mozilla/5.0 (Linux; U; Android 4.1.2; pt-br; LG-E467f Build/JZO54K) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
Accept: application/json, text/plain, */*
Connection: close
20-03-2017 21:09:36
GET /ourapps.php HTTP/1.1
HTTP headers:
Accept-Language: pt-BR,en-US;q=0.8
Accept-Encoding: gzip,deflate
User-Agent: Mozilla/5.0 (Linux; Android 4.4.2; SM-G355M Build/KOT49H) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/30.0.0.0 Mobile Safari/537.36
Accept: application/json, text/plain, */*
Connection: close
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}