using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Foo\b.*(?:\n(?!Yes\b|Foo\b).*)*\nYes\b";
string input = @"Foo $var1
.........
.........
Foo $var2
..........
..........
..........
Yes
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}