$re = '/^Foo\b.*(?:\n(?!Yes\b|Foo\b).*)*\nYes\b/m';
$str = 'Foo $var1
.........
.........
Foo $var2
..........
..........
..........
Yes
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);