use strict;
my $str = '+639123456789';
my $regex = qr/^\+63/mp;
my $subst = '0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";