import Foundation
let pattern = #"^\+63"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"+639123456789"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)