// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".").unwrap();
let string = "An de snou frai and de colei grei Chicago mun beby beibi Charlis morlis de In the guetto (In the guetooo). An de jar mama crai Cosinifi guan sido sido ni modrili yian grin monfi in de gue e to.
[my_shortcode id=\"1\" type=\"lorem\"]lorem ipsum dolor sit amet[/my_shortcode]
Pipol yon ondre tain de chili jil pija. E jil grou yon gui yon man dei. Toque lo que yu an mi. A güi chi blai chu si. De güi simpli ten an qüen. Anblon delon de güei Güedengüelten.
[my_shortcode id=\"2\" type=\"In-sollicitudin\"]In sollicitudin
ullamcorper dolor[/my_shortcode]
A de güelguei jei qui lo you güi re ni brus prisis tri yi guai brus in de guetoooo. An de jan gai ben. So si estarer churruan estrit nai li chus tul fili ji fanch fisin de gueto (In the guetooo).";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}