using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<\*{1}\d+|\<";
string input = @"abc<*15<<def<*3ghi
jkl<42<<mno<7pqrst";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}