$re = '`\<\*{1}\d+|\<`';
$str = 'abc<*15<<def<*3ghi
jkl<42<<mno<7pqrst';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);