#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<pre>(?<line>\d+\..+)<\/pre>"
Local $sString = "table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre>1. APEAL/890/2010 HUSSAIN ISMAIL SATWILKAR SHRI C.K. PENDSE</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> [Criminal] MS.ROHINI DANDEKAR ADV.AP</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> V/S THE STATE OF MAHARASH PTD AS PER CTS ORD 7/9/17</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> TRA P.P.FOR P. P</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre></pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> REMARK : (By Accused against Conviction) Note: (1) Matter is Ready for final</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> hearing. (2) Accd. is in jail. (3) R & P with PB received. (4)</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> Muddemal article are to be called for. (5) Report received from</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> Nashik Central Prison stated therein that "Orig. accd. death dated</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> 20/11/2015 (Report kept at flag "A") . ....... Court (DB) for final</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> hearing.</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre></pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre></pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre></pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre>2. APEAL/966/2011 ABDUL MALIK SHAIKH SHRI S. R. MITHARE</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> [Criminal]</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <pre> V/S THE STATE OF MAHARASH</pre>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")