$re = '/<pre>(?<line>\d+\..+)<\/pre>/m';
$str = 'table>
<tr>
<td>
<pre>1. APEAL/890/2010 HUSSAIN ISMAIL SATWILKAR SHRI C.K. PENDSE</pre>
</td>
</tr>
<tr>
<td>
<pre> [Criminal] MS.ROHINI DANDEKAR ADV.AP</pre>
</td>
</tr>
<tr>
<td>
<pre> V/S THE STATE OF MAHARASH PTD AS PER CTS ORD 7/9/17</pre>
</td>
</tr>
<tr>
<td>
<pre> TRA P.P.FOR P. P</pre>
</td>
</tr>
<tr>
<td>
<pre></pre>
</td>
</tr>
<tr>
<td>
<pre> REMARK : (By Accused against Conviction) Note: (1) Matter is Ready for final</pre>
</td>
</tr>
<tr>
<td>
<pre> hearing. (2) Accd. is in jail. (3) R & P with PB received. (4)</pre>
</td>
</tr>
<tr>
<td>
<pre> Muddemal article are to be called for. (5) Report received from</pre>
</td>
</tr>
<tr>
<td>
<pre> Nashik Central Prison stated therein that "Orig. accd. death dated</pre>
</td>
</tr>
<tr>
<td>
<pre> 20/11/2015 (Report kept at flag "A") . ....... Court (DB) for final</pre>
</td>
</tr>
<tr>
<td>
<pre> hearing.</pre>
</td>
</tr>
<tr>
<td>
<pre></pre>
</td>
</tr>
<tr>
<td>
<pre></pre>
</td>
</tr>
<tr>
<td>
<pre></pre>
</td>
</tr>
<tr>
<td>
<pre>2. APEAL/966/2011 ABDUL MALIK SHAIKH SHRI S. R. MITHARE</pre>
</td>
</tr>
<tr>
<td>
<pre> [Criminal]</pre>
</td>
</tr>
<tr>
<td>
<pre> V/S THE STATE OF MAHARASH</pre>
</td>
</tr>
<tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);