#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(?:\b(?:log|test)\b)|[*\/]).*\b(?:key|secret)\b.*=.*$"
Local $sString = "I have a secret =" & @CRLF & _
"The key = opens the door" & @CRLF & _
"I have a test secret =" & @CRLF & _
"The log has a key =" & @CRLF & _
"Hello World"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")