$re = '/^(?!.*(?:\b(?:log|test)\b)|[*\/]).*\b(?:key|secret)\b.*=.*$/m';
$str = 'I have a secret =
The key = opens the door
I have a test secret =
The log has a key =
Hello World';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);