#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<createdAt>\d+)?:?(?<uuids>(?:[0-9a-f]{8}-[0-9a-f]{4}-4[0-9a-f]{3}-[89ab][0-9a-f]{3}-[0-9a-f]{12}[,]?)+):(?<revisionHash>[a-f0-9]{32}):(?<json>.*)$"
Local $sString = "Without creation date (backwards-compatibility):" & @CRLF & _
"" & @CRLF & _
"92f1a31b-47ca-49c8-a8b7-dc4083cb4d82:eab5627c1f4d3ee1c4dc6d7c80338562:{"2":[15],"3":[28],"5":[14]}" & @CRLF & _
"" & @CRLF & _
"Without creation date (backwards-compatibility) with multiple UUIDs:" & @CRLF & _
"" & @CRLF & _
"4907ee3b-21a9-467a-b90a-2aba97cf1924,bb1513e7-df1d-4387-b022-543c05484737:eab5627c1f4d3ee1c4dc6d7c80338562:{"2":[15],"3":[28]}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"With creation date (backwards-compatibility) with multiple UUIDs:" & @CRLF & _
"" & @CRLF & _
"1676837294:4907ee3b-21a9-467a-b90a-2aba97cf1924,bb1513e7-df1d-4387-b022-543c05484737:eab5627c1f4d3ee1c4dc6d7c80338562:{"2":[15],"3":[28]}" & @CRLF & _
"" & @CRLF & _
"New format:" & @CRLF & _
"1676837294:4907ee3b-21a9-467a-b90a-2aba97cf1924,bb1513e7-df1d-4387-b022-543c05484737:eab5627c1f4d3ee1c4dc6d7c80338562:{"d":{"2":[15],"3":[28]},"bc":"main_all"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")