package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<createdAt>\d+)?:?(?<uuids>(?:[0-9a-f]{8}-[0-9a-f]{4}-4[0-9a-f]{3}-[89ab][0-9a-f]{3}-[0-9a-f]{12}[,]?)+):(?<revisionHash>[a-f0-9]{32}):(?<json>.*)$`)
var str = `Without creation date (backwards-compatibility):
92f1a31b-47ca-49c8-a8b7-dc4083cb4d82:eab5627c1f4d3ee1c4dc6d7c80338562:{"2":[15],"3":[28],"5":[14]}
Without creation date (backwards-compatibility) with multiple UUIDs:
4907ee3b-21a9-467a-b90a-2aba97cf1924,bb1513e7-df1d-4387-b022-543c05484737:eab5627c1f4d3ee1c4dc6d7c80338562:{"2":[15],"3":[28]}
With creation date (backwards-compatibility) with multiple UUIDs:
1676837294:4907ee3b-21a9-467a-b90a-2aba97cf1924,bb1513e7-df1d-4387-b022-543c05484737:eab5627c1f4d3ee1c4dc6d7c80338562:{"2":[15],"3":[28]}
New format:
1676837294:4907ee3b-21a9-467a-b90a-2aba97cf1924,bb1513e7-df1d-4387-b022-543c05484737:eab5627c1f4d3ee1c4dc6d7c80338562:{"d":{"2":[15],"3":[28]},"bc":"main_all"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}