import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[QUOTE=)";
final String string = "[QUOTE=UserAdmin;22061013][SIZE=\"4\"] [LEFT] [COLOR=\"DarkGreen\"] Sample text goes here [/COLOR] [/LEFT] [/SIZE][/QUOTE]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}