// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\[QUOTE=)").unwrap();
let string = "[QUOTE=UserAdmin;22061013][SIZE=\"4\"] [LEFT] [COLOR=\"DarkGreen\"] Sample text goes here [/COLOR] [/LEFT] [/SIZE][/QUOTE]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}