package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:[01][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]\b`)
var str = `23:59:59`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}