const regex = /\b(?:[01][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:[01][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]\\b', 'g')
const str = `23:59:59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}