package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[a-z]{0,2}[0-9]{6}[SDL]*`)
var str = `CA123456SDL OR CA123456 OR 123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}