$re = '/[a-z]{0,2}[0-9]{6}[SDL]*/mi';
$str = 'CA123456SDL OR CA123456 OR 123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);