package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^java\.lang\..*?Exception:`)
var str = `java.lang.NoSuchMethodException: ...
java.lang.IllegalAccessException: ...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}