$re = '`^java\.lang\..*?Exception:`m';
$str = 'java.lang.NoSuchMethodException: ...
java.lang.IllegalAccessException: ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);