const regex = /\s*(?:\$\d+\s*)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?:\\$\\d+\\s*)+', 'gm')
const str = `\$1 \$2 \$3 \$5 \$7 hello`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);