use strict;
my $str = '2-2-2016';
my $regex = qr/^(?:(?:(0?[13578]|1[02])([\-.\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\-.\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\-.\/])(0?[1-9]|[12][0-9]))(?:\2|\5|\8)((?:16|[357][26]|[2468][048])(?:[0248][048]|[13579][26])|(?:1[6-9]|[2-9][0-9])(?:0[48]|[13579][26]|[2468][048])|(?:15)(?:84|9[048]))|(?:(0?[13578]|1[02])([\-.\/])(0?[1-9]|[12][0-9]|3[01])|(0?[469]|11)([\-.\/])(0?[1-9]|[12][0-9]|30)|(0?2)([\-.\/])(0?[1-9]|1[0-9]|2[0-8]))(?:\12|\15|\18)((?:16|[357][26]|[2468][048])(?:0[1235679]|[13579][01345789]|[2468][1235679])|(?:1[789]|[35679][01345789]|[248][12345679])(?:0[01235679]|[13579][01345789]|[2468][1235679])|(?:15)(?:8[235679]|9[01345789])))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}