using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\p{L}){2,}.*";
string input = @"322332лд233-
ваыфаы
в43-ава-аа()?::%4
ВАЫЙФУ
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}