#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)\s*متر"
Local $sString = "زیرزمین ۱۳۰ متری تک خواب نقاشی شده وتمیز بلوار فلسطین" & @CRLF & _
"شهرک فرهنگیان ۲م رهن با ۸۵۰ت" & @CRLF & _
"فقط خانواده " & @CRLF & _
"املاک عباسی ۳۸۲۰۱۳۱۳"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")