import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s*متر";
final String string = "زیرزمین ۱۳۰ متری تک خواب نقاشی شده وتمیز بلوار فلسطین\n"
+ "شهرک فرهنگیان ۲م رهن با ۸۵۰ت\n"
+ "فقط خانواده \n"
+ "املاک عباسی ۳۸۲۰۱۳۱۳";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}