re = /"?(.*)"? </i
str = 'peter@pan.com
lucky <jack@pot.com>
"William Tell" <billy@tell.com>
"John Rambo, III" <johnny@rambo.com>
"there, might, be, several, commas inside the quotes" <multiple@commas.com>
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end