// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)"?(.*)"? <"#).unwrap();
let string = "peter@pan.com
lucky <jack@pot.com>
\"William Tell\" <billy@tell.com>
\"John Rambo, III\" <johnny@rambo.com>
\"there, might, be, several, commas inside the quotes\" <multiple@commas.com>
\"yes, this is also a valid email address, can you believe\" <yes@this@is@valid.com>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}