package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b(\p{Lu}\w*(?:\s+\p{Lu}\w*)*)(?:\s+et\s+al\.)?)?\s*\(([^()]*\d{4})\)`)
var str = `This is a test. I only want to select the (cites) in parenthesis. I do not want it to return words in parenthesis that do not have years attached, such as abbreviations (abbr). For example, citing (Smith 2010) is something I would want to be returned. I would also want multiple citations returned separately such as (Smith 2010; Jones 2001; Brown 2020). I would also want Cooper et al. (2015) returned as Cooper 2015, and not just 2015.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}