re = /(?:\b(\p{Lu}\w*(?:\s+\p{Lu}\w*)*)(?:\s+et\s+al\.)?)?\s*\(([^()]*\d{4})\)/m
str = 'This is a test. I only want to select the (cites) in parenthesis. I do not want it to return words in parenthesis that do not have years attached, such as abbreviations (abbr). For example, citing (Smith 2010) is something I would want to be returned. I would also want multiple citations returned separately such as (Smith 2010; Jones 2001; Brown 2020). I would also want Cooper et al. (2015) returned as Cooper 2015, and not just 2015.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end