package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\.(\d{4}):[^"]+"\s*(included with your TV purchase|.*)"$`)
var str = `eamoptns.ftr.0009: LoyaltyPrint3 = " included with your TV purchase"
eamoptns.ftr.0010: LoyaltyPrint3 = " included with your TV purchase"
eamoptns.ftr.0011: LoyaltyPrint3 = " blabla"
Grand Total: 2 match(es) found.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}