$re = '/(?=a(?:bc|cb)|b(?:ca|ac)|c(?:ab|ba))\w+/';
$str = 'abc acb bac bca cab cba ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);