package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+(?<url>[^\.]+).*\s+(?<ip>\d+\.\d+\.\d+\.\d+)`)
var str = ` 853727-gcplusrspcndb01.usa.corp.ad
10.198.29.5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}