import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n"
+ " (?:\\n|\\A)[ ]*\n"
+ " # 1: Opening marker\n"
+ " (\n"
+ " [ ]{0,2}(?:~{3,}|`{3,}) # 3 or more tildes/backticks.\n"
+ " )\n"
+ " [ ]*\n"
+ " (?:\n"
+ " \\.?([\\w-_:\\.\\/\\{\\+\\},\\@]+) # 2: standalone class name\n"
+ " |\n"
+ " \\{((?:[ ]*[#.][-_:a-zA-Z0-9]+){1,})[ ]*\\} # 3: Extra attributes\n"
+ " )?\n"
+ " [ ]* \\n # Whitespace and newline following marker.\n"
+ " \n"
+ " # 4: Content\n"
+ " (\n"
+ " (?>\n"
+ " (?!\\1 [ ]* \\n) # Not a closing marker.\n"
+ " .*\\n+\n"
+ " )+\n"
+ " )\n"
+ " \n"
+ " # Closing marker.\n"
+ " \\1 [ ]* (?= \\n )";
final String string = "\n\n"
+ "B1B\n\n\n\n"
+ "{{ site.data.reusables.ssh.dsa-support }}\n\n"
+ "{{ site.data.reusables.command_line.open_the_multi_os_terminal }}\n\n"
+ "2. Enter `ls -al ~/.ssh` to see if existing SSH keys are present:\n\n"
+ "```shell\n"
+ " $ ls -al ~/.ssh\n"
+ " # Lists the files in your .ssh directory, if they exist\n"
+ "```\n"
+ "dadas\n"
+ "dasdasdasda\n\n"
+ " ~~~dadasd\n"
+ "$ ls -al ~/.ssh\n"
+ "# Lists the files in your .ssh directory, if they exist\n"
+ " ~~~\n"
+ "3. Check the directory listing to see if you already have a public SSH key.\n\n"
+ "By default, the filenames of the public keys are one of the following:\n\n"
+ "* *id_dsa.pub*\n"
+ "* *id_ecdsa.pub*\n"
+ "* *id_ed25519.pub*\n"
+ "* *id_rsa.pub*\n\n"
+ "- If you don't have an existing public and private key pair, or don't wish to use any that are available to connect to GitHub, then [generate a new SSH key](/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent).\n"
+ "- If you see an existing public and private key pair listed (for example *id_rsa.pub* and *id_rsa*) that you would like to use to connect to GitHub, you can [add your SSH key to the ssh-agent](/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent/#adding-your-ssh-key-to-the-ssh-agent).\n\n"
+ "{{#tip}}\n\n"
+ "**Tip:** If you receive an error that *~/.ssh* doesn't exist, don't worry! We'll create it when we [generate a new SSH key](/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent).\n\n"
+ "{{/tip}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}