const regex = /
(?:\n|\A)[ ]*
# 1: Opening marker
(
[ ]{0,2}(?:~{3,}|`{3,}) # 3 or more tildes/backticks.
)
[ ]*
(?:
\.?([\w-_:\.\/\{\+\},\@]+) # 2: standalone class name
|
\{((?:[ ]*[#.][-_:a-zA-Z0-9]+){1,})[ ]*\} # 3: Extra attributes
)?
[ ]* \n # Whitespace and newline following marker.
# 4: Content
(
(?>
(?!\1 [ ]* \n) # Not a closing marker.
.*\n+
)+
)
# Closing marker.
\1 [ ]* (?= \n )/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('
(?:\\n|\\A)[ ]*
# 1: Opening marker
(
[ ]{0,2}(?:~{3,}|`{3,}) # 3 or more tildes\/backticks.
)
[ ]*
(?:
\\.?([\\w-_:\\.\\\/\\{\\+\\},\\@]+) # 2: standalone class name
|
\\{((?:[ ]*[#.][-_:a-zA-Z0-9]+){1,})[ ]*\\} # 3: Extra attributes
)?
[ ]* \\n # Whitespace and newline following marker.
# 4: Content
(
(?>
(?!\\1 [ ]* \\n) # Not a closing marker.
.*\\n+
)+
)
# Closing marker.
\\1 [ ]* (?= \\n )', 'mg')
const str = `
B1B
{{ site.data.reusables.ssh.dsa-support }}
{{ site.data.reusables.command_line.open_the_multi_os_terminal }}
2. Enter \`ls -al ~/.ssh\` to see if existing SSH keys are present:
\`\`\`shell
\$ ls -al ~/.ssh
# Lists the files in your .ssh directory, if they exist
\`\`\`
dadas
dasdasdasda
~~~dadasd
\$ ls -al ~/.ssh
# Lists the files in your .ssh directory, if they exist
~~~
3. Check the directory listing to see if you already have a public SSH key.
By default, the filenames of the public keys are one of the following:
* *id_dsa.pub*
* *id_ecdsa.pub*
* *id_ed25519.pub*
* *id_rsa.pub*
- If you don't have an existing public and private key pair, or don't wish to use any that are available to connect to GitHub, then [generate a new SSH key](/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent).
- If you see an existing public and private key pair listed (for example *id_rsa.pub* and *id_rsa*) that you would like to use to connect to GitHub, you can [add your SSH key to the ssh-agent](/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent/#adding-your-ssh-key-to-the-ssh-agent).
{{#tip}}
**Tip:** If you receive an error that *~/.ssh* doesn't exist, don't worry! We'll create it when we [generate a new SSH key](/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent).
{{/tip}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}