use strict;
my $str = '@badge-info=;badges=broadcaster/1,premium/1;client-nonce=8f8a16f3582a7b95bc270350fe1a635d;color=#D2691E;display-name=buckybubba;emotes=;first-msg=0;flags=;id=26e18d04-2e0d-41d9-a8e9-925a434d7142;mod=0;returning-chatter=0;room-id=460209762;subscriber=0;tmi-sent-ts=1690833107242;turbo=0;user-id=460209762;user-type= :buckybubba!buckybubba@buckybubba.tmi.twitch.tv PRIVMSG #buckybubba :Test';
my $regex = qr/^@[^=]*?=(?<badgeinfo>.*?);[^=]*?=(?<badges>.*?);c[^=]*?=(?<clientNonce>.*?);[^=]*?=(?<color>.*?);[^=]*?=(?<name>.*?);[^=]*?=(?<emojis>.*?);[^=]*?=(?<firstMsg>.*?);[^=]*?=(?<flags>.*?);[^=]*?=(?<id>.*?);[^=]*?=(?<mod>.*?);[^=]*?=(?<returningChatter>.*?)[^=]*?=(?<roomId>.*?);[^=]*?=(?<sub>.*?);[^=]*?=(?<tmi>.*?);[^=]*?=(?<turbo>.*?);[^=]*?=(?<userId>.*?);[^=]*?=(?<userType>.*?):[^=]*? :(?<message>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}