import Foundation
let pattern = #"^@[^=]*?=(?<badgeinfo>.*?);[^=]*?=(?<badges>.*?);c[^=]*?=(?<clientNonce>.*?);[^=]*?=(?<color>.*?);[^=]*?=(?<name>.*?);[^=]*?=(?<emojis>.*?);[^=]*?=(?<firstMsg>.*?);[^=]*?=(?<flags>.*?);[^=]*?=(?<id>.*?);[^=]*?=(?<mod>.*?);[^=]*?=(?<returningChatter>.*?)[^=]*?=(?<roomId>.*?);[^=]*?=(?<sub>.*?);[^=]*?=(?<tmi>.*?);[^=]*?=(?<turbo>.*?);[^=]*?=(?<userId>.*?);[^=]*?=(?<userType>.*?):[^=]*? :(?<message>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"@badge-info=;badges=broadcaster/1,premium/1;client-nonce=8f8a16f3582a7b95bc270350fe1a635d;color=#D2691E;display-name=buckybubba;emotes=;first-msg=0;flags=;id=26e18d04-2e0d-41d9-a8e9-925a434d7142;mod=0;returning-chatter=0;room-id=460209762;subscriber=0;tmi-sent-ts=1690833107242;turbo=0;user-id=460209762;user-type= :buckybubba!buckybubba@buckybubba.tmi.twitch.tv PRIVMSG #buckybubba :Test"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)